Welcome, Guest
Username: Password: Remember me
A forum for owners and fans of Chrysler and Force engines.
  • Page:
  • 1

TOPIC: 55hp Chrysler problem solved

55hp Chrysler problem solved 6 years 8 months ago #98534

  • Hugh Long
  • Hugh Long's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 261
  • Karma: 8
  • Thank you received: 2
In some of my trading last fall, I came up with 2 55 hp Chrysler's. A 1973 Magneto fired, and a 1975 12v point coil ign. Both have 120# comp. I think they made good outboards in those years and easy to work on.
Anyway I put '75 all tuned up on my '48 Clipper ran in the barrel. Went to lake, fired it up, took off. Ran great for about 10 min then started going bad. to make a long story short, I worked on it for 10 days on and off. I redid everything to no avail. :angry: Today I pulled the flywheel and there it was. A condenser bouncing around with the screw broken off rubbing the flywheel. SOMEONE didn't tighten the screw. :S
Will take it to the lake next week.
Glad to see this forum for other outboards as there were many good ones built.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.282 seconds

FG Login

Donate

Please consider supporting our efforts.

Glassified Ads

Complete Gator trailer (all parts)
( / Trailers)

Complete Gator trailer (all parts)
04-14-2021

Sport Hydrofoil
( / Parts / Miscellaneous)

Sport Hydrofoil
04-12-2021

Seacamper wanted
( / Wanted)

noimage
04-11-2021

FiberGoogle

Who's Online

We have 7453 guests and 3 members online