Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: 1966 Merc 500 fuel pump problem

1966 Merc 500 fuel pump problem 3 weeks 4 hours ago #142922

  • otto
  • otto's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 0
1966 Merc 500 , I installed a new fuel pump diaphragm kit and it is still not working,fires up and runs at idle but dies at full throttle.I disconnected line going to carbs only slight dribble when cranking over.

Please Log in to join the conversation.

1966 Merc 500 fuel pump problem 2 weeks 6 days ago #142923

Otto,
I moved this to the Merc forum where you'll get inputs from the Merc folks . ;)

Bob

Please Log in to join the conversation.

1966 Merc 500 fuel pump problem 2 weeks 6 days ago #142929

Check the fuel flow coming from your fuel tank.
Look for hose that is collapsed inside, prime bulb failure, vent on the fuel tank.
Did you replace the (2) valves in the fuel pump? One valve should suck, but not blow, and the other should blow, but not suck.
If you detect any leaking by, replace the valves.
If the Merc starts and idles okay, but stalls as you attempt to speed up, try adjusting the idle jets on both carburetors. Open them both 1/8th of a turn and try to accelerate, if she still stalls, repeat the adjustment an 1/8th turn more, etc.
Counter-clockwise opens these jets.
doc

Please Log in to join the conversation.

1966 Merc 500 fuel pump problem 2 weeks 5 days ago #142933

  • otto
  • otto's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 0
This is a user boat and motor ran good last year,and have been using it for at least 10 summers. I am wondering if there is not a weird internal problem with vacuum before the fuel pump.I have gone through and Checked all these things,taken the fuel pump apart several times . New fuel line and primer bulb. I would think fuel should flow out strong from the fuel pump when you crank the motor over ,? little to nothing does at this time, the fuel line is not clogged because when I prime the bulb there is good flow. Thanks for your help.

Please Log in to join the conversation.

1966 Merc 500 fuel pump problem 2 weeks 4 days ago #142943

Awesome thanks for helping Doc!

Bob

Please Log in to join the conversation.

1966 Merc 500 fuel pump problem 3 days 19 hours ago #143025

  • otto
  • otto's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 0
I think I finally fixed the fuel problem, thought I had it fixed a few weeks ago ran great,but then failed again, I took fuel line off between fuel pump and carbs,and there was a non visible obstruction in it.replace black rubber fuel line and runs good again.frustrating because I can see no problem with the old Line except that it is 54 yours old.maybe some kinda internal collapse. Thanks again for your help.I am learning all the time to keep these old motors running!
Attachments:

Please Log in to join the conversation.

  • Page:
  • 1
Time to create page: 0.147 seconds

FG Login

Donate

Please consider supporting our efforts.

Glassified Ads

14ft. 1957 searay
( / Boats)

14ft. 1957 searay
08-11-2020

59 wizard marlin cruiser 18' cuddy cabin
( / Boats)

59 wizard marlin cruiser 18' cuddy cabin
08-04-2020

1968 Johnson Model 121201E
( / Boats)

1968 Johnson Model 121201E
08-04-2020

FiberGoogle

Quick Search

Who's Online

We have 2808 guests and 4 members online