Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: 1968 Johnson 65hp outboard

1968 Johnson 65hp outboard 4 months 3 weeks ago #140255

  • ptrk_1969
  • ptrk_1969's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Karma: -1
  • Thank you received: 0
just a question to pick some brains. I purchased a new power pack and coil for my outboard and installed (as far as I knew its the right way wired up). I turn the key to "on"and I have juice going into the power pack but it makes a ticking noise with power on. I also get weak juice coming out to the points but am not getting any juice coming out to the coil with the key in "ON" or by cranking the engine. any ideas as to what it might be or maybe I dont have something wired right? Thanks

Please Log in to join the conversation.

1968 Johnson 65hp outboard 3 months 3 weeks ago #140602

  • ptrk_1969
  • ptrk_1969's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Karma: -1
  • Thank you received: 0
Thanks for nothing everyone---figured it out myself and it is the battery. This site is useless, if you want real answers then take it to a shop--it might cost you but at least you will get answers.

Please Log in to join the conversation.

1968 Johnson 65hp outboard 3 months 3 weeks ago #140625

Sorry for your disappointment. I have always had good luck on this site. There are a lot of very knowledgeable people involved here. Maybe if you posted your question on the J.E.G.O.s page you might have had better luck. Don't give up on the site so quickly.
Bill

Please Log in to join the conversation.

1968 Johnson 65hp outboard 3 months 3 weeks ago #140650

  • jon_a
  • jon_a's Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 105
  • Karma: 6
  • Thank you received: 1
the best place to post outboard motor questions is not this site. aomci.org is the antqiue outboard motor club. they have a facebook page where a lot of people ask for and get help/advice.

ptrk_1969 wrote: just a question to pick some brains. I purchased a new power pack and coil for my outboard and installed (as far as I knew its the right way wired up). I turn the key to "on"and I have juice going into the power pack but it makes a ticking noise with power on. I also get weak juice coming out to the points but am not getting any juice coming out to the coil with the key in "ON" or by cranking the engine. any ideas as to what it might be or maybe I dont have something wired right? Thanks

Please Log in to join the conversation.

  • Page:
  • 1
Time to create page: 0.126 seconds

FG Login

Donate

Please consider supporting our efforts.

Glassified Ads

Larson Thunder Hawk JR
( / Boats)

Larson Thunder Hawk JR
11-28-2019

1957 skagit 17 foot convertible inboard
( / Boats)

1957 skagit 17 foot convertible inboard
11-23-2019

Power Trim Gauge-NOS Mercury
( / Parts / Miscellaneous)

Power Trim Gauge-NOS Mercury
11-20-2019

FiberGoogle

Quick Search

Who's Online

We have 3656 guests and 6 members online